Max Planilhas

Utilizando a Função PROCX no Excel

função PROCX capa

Diferente das funções PROCV e PROCH, com a função PROCX você conseguirá fazer busca de informações na vertical e na horizontal. Ou seja, com essa incrível função PROCX no Excel você conseguirá fazer as duas buscas com uma única função, oferecendo uma funcionalidade aprimorada e mais flexível.

Neste artigo, vamos te mostrar a estrutura da função e como ela funciona no Excel, acompanhe até o final e pratique posteriormente.

Sintaxe da Função PROCX

Primeiramente, conheça a estrutura da função PROCX, ela é dividida em 6 argumentos, dos quais 3 são obrigatórios, e neste artigo focaremos apenas nos 4 primeiros argumentos, que são mais usuais.

=PROCX(pesquisa_valor; pesquisa_matriz; matriz_retorno; [se_não_encontrada]; [modo_correspondência]; [modo_pesquisa])

Conheça os argumentos:

Pesquisa_valor – É o valor a ser pesquisado;

Pesquisa_matriz – O intervalo para pesquisar o valor do primeiro argumento;

Matriz_retorno – O intervalo que irá retornar o resultado.

Se_não_encontrada – Retornado se nenhuma correspondência for encontrada, neste argumento você poderá inserir um texto para aparecer nessa situação.

Modo_correspondência – Especificar o tipo de correspondência desejada, ou seja, se correspondência exata ou próxima.

Modo_pesquisa – Especificar o modo de pesquisa a ser usado, ou seja, fazer uma busca de cima para baixo (padrão) ou de baixo para cima.

Exemplo de Aplicação da função PROCX

Para melhor compreensão de como ela funciona, vamos a um exemplo prático. Suponha que tenhamos uma lista de colaboradores, com informações de cargo, área e salário, conforme abaixo. Porém, gostaríamos de realizar uma busca mais aprimorada, onde apenas ao informar o nome do colaborador a função irá trazer o cargo e salário de forma automática.

função PROCX 1

Para isso aplicaremos a função da seguinte forma: =PROCX(H2;B3:B18;C3:C18;”Não Localizado”)

função PROCX 2

Onde nossos argumentos foram:

Pesquisa_valor – Informamos a célula onde está nosso valor de busca, ou seja, célula H2.

Pesquisa_matriz – Informamos o intervalo da tabela correspondente ao valor do nosso primeiro argumento, sendo o intervalo B3:B18, correspondente a coluna de nomes.

Matriz_retorno – Informamos o intervalo da tabela correspondente ao valor que desejamos retornar na função, sendo o intervalo C3:C18, correspondente a coluna de cargos.

Se_não_encontrada – Informamos um texto para aparecer quando nossa busca não for encontrada pela função, sendo “Não Localizado”, entre aspas por se tratar de um texto dentro da função.

Para a função trazer o salário, aplicaremos da mesma forma acima, alterando apenas a matriz de retorno, que passa a ser o intervalo E3:E18, correspondente a coluna de salários.

função PROCX 3

Confira o resultado.

função PROCX 4

E se inserir um nome que não houver na tabela, o nosso texto inserido será informado na função.

função PROCX 5

Vale destacar que, se as informações de qualquer colaborador se alterarem as informações da função serão atualizadas automaticamente.

Pronto! Viu só como foi rápido realizar nossa busca na tabela?! E ainda economizando tempo no Excel. Ao compreender como usar essa função de maneira eficaz, você pode melhorar significativamente sua produtividade e eficiência ao trabalhar com grandes conjuntos de dados no Excel.

Para mais dicas e tutoriais como esse, siga nossa página no Instagram, confira também nossa página no Youtube e veja nossas vídeos aulas.

E caso você precise elaborar uma planilha, e não quer ficar quebrando a cabeça sozinho ao desenvolvê-la, ou não sabe nem por onde começar, entre em contato e solicite seu orçamento para planilha personalizada, elaboramos conforme sua necessidade, 100% personalizada para você ou seu negócio.

Gostou deste Artigo?

Compartilhar no facebook
Compartilhe no Facebook
Compartilhar no twitter
Compartilhe no Twitter
Compartilhar no linkedin
Compartilhe no Linkedin
Compartilhar no whatsapp
Compartilhe WhatsApp

VEJA MAIS...

Deixe um comentário

Deixe um comentário

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Rolar para cima
WhatsApp Chamar no Whatsapp